Welcome to the forum, Guest

TOPIC: Remote Library connects but doesn't show anything

Remote Library connects but doesn't show anything 2 years 7 months ago #4045

gmickd

Offline

Fresh Boarder

Posts: 4

Karma: 0

I was able to connect both my iPhone and my iPad to my PC using the QR code from the YACReaderLibrary, but when I click browse on the app, there is only a blank white screen. I can reload but nothing appears. I have a few cbr and cbz files uploaded to the YACReaderLibrary and have opened all firewalls for both the YACReaderLibrary and YACreaderLibraryServer executables.

Is there something that I need to do to make the files appear in the Remote Library window?

Thanks,

Geoff
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 7 months ago #4047

Luis Ángel

Offline

Administrator

Posts: 1618

Thank you received: 344

Karma: 30

No, you just need to keep the library in YACReaderLibrary updated.

Open a web browser in the computer you are running YACReaderLibrary and enter its IP and the port number you can see in the server dialog (the dialog containing the QR code). Can you browse the library there?
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 7 months ago #4048

gmickd

Offline

Fresh Boarder

Posts: 4

Karma: 0

I am able to connect to localhost:[port] and [localip]:[port] but I get a blank white screen there. It looks like the network side of things is OK, but YACReader is not serving up any content.

When I run netstat -na | find [port] I get the following:

Proto Internal Address Foreign Address Status
TCP 0.0.0.0:[port] 0.0.0.0:0 Listening
TCP [::]:[port] [::]:0 Listening

note: localip and port info have been scrubbed.
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 7 months ago #4049

Luis Ángel

Offline

Administrator

Posts: 1618

Thank you received: 344

Karma: 30

What version are you using 9.0.0? Windows?

Check for a "server" folder the installation directory. Is it there?

Did you try to reinstall YACReader?
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 7 months ago #4051

gmickd

Offline

Fresh Boarder

Posts: 4

Karma: 0

Windows 10 and version 9.0.0.

I've reinstalled and verified that there is content in the server directory (docroot and templates).

Is there a way I can print out some logs to see what is going on?
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 7 months ago #4052

Luis Ángel

Offline

Administrator

Posts: 1618

Thank you received: 344

Karma: 30

You can check the logs in this folder:
C:\Users\USERNAME\AppData\Local\YACReader\YACReaderLibrary

Enabling different log levels is a feature coming after YACReader 9.5.0.

You can try the new versions and see if the problem persists, they are going to be released soon: www.yacreader.com/forum/testers/1172-yac...acreader-3-0-for-ios
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 6 months ago #4053

gmickd

Offline

Fresh Boarder

Posts: 4

Karma: 0

Well I found the cause of the error.

This is what I found in the log file:

TemplateCache: cannot find template libraries_ipad

I opened the YACReaderLibarary.ini file and found that the template and docroot paths were incorrect. Once I fixed those the program worked.

The root cause of the error was that I had downloaded the 9.5.0 version from the github site but then realized that it wasn't a release version so I deleted the 9.5.0 version and installed the release version from the yacreader.com site. However, the YACReaderLibrary.ini file did not update to reflect the change to the install location. It was still pointing to the beta version location which didn't exist anymore.
The administrator has disabled public write access.

Remote Library connects but doesn't show anything 2 years 6 months ago #4054

Luis Ángel

Offline

Administrator

Posts: 1618

Thank you received: 344

Karma: 30

Great!
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.
Powered by Kunena Forum