Welcome to the forum, Guest

TOPIC: Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 4 days ago #5512

Silvestre

Offline

Fresh Boarder

Posts: 8

Karma: 0

YacReaderLibraryServer v 9.6 in my RaspBerry Pi 3B and YacReader app in my iPad were running with no problem at all.

After a problem with the memory card in my RaspBerry device and I had to format the card and make a fresh install of operating system and YacReader.

YacReader is now reinstalled and it seems the be working.

I’ve created a comic library for testing using sudo YACReaderLibraryServer list-libraries. It was succesfully done. YACReaderLibraryServer list-libraries shows my library name.
I’ve started the server using sudo YACReaderLibraryServer --port 8080 start.
sudo YACReaderLibraryServer -v shows YACReaderLibraryServer 9.7.1
Up to here everything seems fine.

My iPAd is running with iOS v14.2
YacReader app is the last one available v3.10.1

And here comes the problem. When I sync iPad to the server in Raspberry using a local IP and port 8080 I get the error: "Server version. You need YACReaderLibrary 9.5.0 o higher”
So the connection is done but it’s not recognizing that the server installed is 9.7.1

Thanks a lot for any help you can provide.
The administrator has disabled public write access.

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 4 days ago #5513

Luis Ángel

Offline

Administrator

Posts: 1816

Thank you received: 389

Karma: 36

How did you install the server?

Can you try running YACReaderLibrary instead?
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 4 days ago #5514

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

What is the output of YACReaderLibraryServer --version ?

Try running YACReaderLibraryServer start --loglevel=info and check for warnings and errors after start and when connecting to the server.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 3 days ago #5515

Silvestre

Offline

Fresh Boarder

Posts: 8

Karma: 0

Thanks a lot for your answers. I’ve find a transitory solution but the problem is not solved.

If I run ‘YACReaderLibraryServer -start’ in the console of my RaspberryPi it runs but it is assigning a different local port each time. If I consider this local port in my iPad the app runs with no problem. I can browse and read my comics. I had understood that the default port for YacReader was 8080. I’ve been working up to the previous installment by assigning YacReder in my router as a virtual server and reserving external and internal ports 8080 under the TCP protocol. It was working before and it’s not working now.

When I run ‘YACReaderLibraryServer –port 8080 -start’ it seems to run. See the attached screen:
pi@raspberrypi:~ $ YACReaderLibraryServer --port 8080 start --loglevel=info
INFO 2020-11-16T15:49:30.138 YACReaderLibraryServer attempting to start
INFO 2020-11-16T15:49:30.156
System & configuration
INFO 2020-11-16T15:49:30.156 OS: "Raspbian GNU/Linux 10 (buster)" Version: "10"
INFO 2020-11-16T15:49:30.157 Kernel: "linux" "5.4.72-v7+" Architecture: "arm"
INFO 2020-11-16T15:49:30.157 Libraries: QMap(("Comics", QPair(2,"/media/pi/nubeBiblioteca/Comics")))
INFO 2020-11-16T15:49:30.157
INFO 2020-11-16T15:49:30.158 YACReaderLibrary starting
INFO 2020-11-16T15:49:30.158 Running on port "8080"
And see the version that is running:
pi@raspberrypi:~ $ YACReaderLibraryServer -v
YACReaderLibraryServer 9.7.1
But I get this initial error in my iPad:
“Error. The data couldn’t be read because it isn’t in the correct format”
When I close the error window and I try to reconnect again I get this error in my iPad:
“Error. You need YACReaderLibrary 9.5.0 or higher”
If I go to the browser either in W10 or Raspberry and I run LocalAddress:8080 I get this message:
“Too many connections”
Adding ‘--loglevel=info’ at the end of the command is not providing additional information.

I’ve tried to include in the command a port previously defined by YacReader that was producing a proper connection. E,g, port 34387. But when I run
‘YACReaderLibraryServer --port 34387 start --loglevel=info’
I get the same output as shown previously with port 8080 and the same error problem.
So for some reason I’m not able to define the port to be used. The only way to get YacReaderLibraryServer working is using the random port get each time that the command is run.

Thanks again for your support and guidance to get a solution.
The administrator has disabled public write access.

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 3 days ago #5516

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

You can set a permanent port via YACReaderLibraryServer set-port some_number. So first run YACReaderLibraryServer set-port 9090 (or any port you want) and then start the server via YACReaderLibraryServer start.
The random port only is triggered when the port you want already is taken and it can't bind.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: Silvestre

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 3 days ago #5517

Luis Ángel

Offline

Administrator

Posts: 1816

Thank you received: 389

Karma: 36

I think the problem is that the ios app is hitting a different server running at 8080, when it request the server version it gets a not found http error (404), so the app thinks that the server is a pre 9.5 version.

So please, set a different port, and before using it, make sure that there is no other server running at that port.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.
The following user(s) said Thank You: Silvestre

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 3 days ago #5518

Silvestre

Offline

Fresh Boarder

Posts: 8

Karma: 0

Thank you for your proposed solutions. It's solved.

I´ve checked that no other server is running at port 8080.

I've edited the YACReaderLibrary.ini file, and added the port line under "listener":
[listener]
port=8080

and now it works in port 8080. I don't know why it didn't use this port by default, as no other process was using it. But anyway it works great now, so thank you!
The administrator has disabled public write access.

Bug in YacReaderLIbrary 9.7.1 and/or iPad app 3.10 11 months 3 days ago #5519

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

The way the port is handled was slightly changed in the 9.7 series to allow for better configuration. Running YACReaderLibraryServer set-port 8080 should have set the port in the config file.

I don't know why the temporary port setting via --port (*not* the same as set-port) failed for you. Alas, as I don't own any Apple devices capable of running the iOS app I can't test this.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
Powered by Kunena Forum