Welcome to the forum, Guest

TOPIC: yacreader can't recognize any file type

yacreader can't recognize any file type 2 years 2 months ago #4334

corgiking

Offline

Fresh Boarder

Posts: 1

Thank you received: 1

Karma: 0

I tried to open some files with the reader but it can't recognize any, eg. zip or rar. However, I can open the files with the "open with" > "other"...

I even try 8.5, still no luck.

any idea?

MacOs 10.13.6.

thanks
Vic
The administrator has disabled public write access.
The following user(s) said Thank You: LukeInDC

yacreader can't recognize any file type 2 years 1 month ago #4377

Luis Ángel

online

Administrator

Posts: 1611

Thank you received: 342

Karma: 30

I didn't have time to look into this yet, it something I have to fix.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 3 months ago #4846

LukeInDC

Offline

Fresh Boarder

Posts: 2

Karma: 0

This problem can be fixed as follows:
Select a file (somecomic.cbr or someothercomic.cbz) in finder. Press "CMD i" (That's the Command Key and the letter I as in India)
In the info box that pops up, choose "Open With". Scroll to "Other", Enable "All Applications" in the drop down. Find Yacreader, click on it then click add.
Click the "Change All" button just below the Open With (which should now show YACReader.app).
Click "Continue". Now all your comics should open with yacreader when you double click them. You'll need to do it for both file types (.cbr and .cbz).

The reason why this occurs is because some where in the coding, YACReader doesn't notify MacOS that it is able to open .cbr and .cbz files nor does it try to make itself the default for opening these file types. I'm not a programmer so I can't tell you how to set this up in your code but I do know that is the reason.
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 3 months ago #4847

Luis Ángel

online

Administrator

Posts: 1611

Thank you received: 342

Karma: 30

Actually YACReader tells the SO about the supported extensions: github.com/YACReader/yacreader/blob/deve...YACReader/Info.plist

I changed how YACReader for iOS exposes that information recently and I need to do the same in the desktop version I think, the docs are not very clear and I have see people doing very different things to achieve the desired result.

@LukeInDC thanks for sharing those steps.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 3 months ago #4849

LukeInDC

Offline

Fresh Boarder

Posts: 2

Karma: 0

Is there a way for me to manually force the OS to recognize the info.plist? I'd especially like for the icon to change from the current blank icon to the yacreader icon
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 3 months ago #4854

Luis Ángel

online

Administrator

Posts: 1611

Thank you received: 342

Karma: 30

Give a few days and I'll try to improve that so you can test it with a dev build.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 3 months ago #4867

Luis Ángel

online

Administrator

Posts: 1611

Thank you received: 342

Karma: 30

Plase, try this dev version: bintray.com/beta/#/luisangelsm/YACReader...ds/1910202?tab=files

Right click -> open with should work now.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 3 months ago #4882

logansdaddy921

Offline

Fresh Boarder

Posts: 2

Karma: 0

Thank you. Build works great and resolves issues although i was already using the work around.

I was hoping this would resolve the issue in MacOS that keeps the YACreader icon from propagating correctly to all file types set to open to YACearder by default. Ive tried every fix i could find from re-writing the .plist to rebuilding the .icons package with no luck. I saw this issue was brought once before nearly a year ago. I know its very minor but any insight into a work around or proper fix? Thank you.
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 2 months ago #4885

Luis Ángel

online

Administrator

Posts: 1611

Thank you received: 342

Karma: 30

Yeah, the icon is a separate issue, I need to add it. The list of things to do is so huge that even small things like this take time.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

yacreader can't recognize any file type 1 year 2 months ago #4886

logansdaddy921

Offline

Fresh Boarder

Posts: 2

Karma: 0

Completely understood. Thanks for the quick response!
The administrator has disabled public write access.
Powered by Kunena Forum