Welcome to the forum, Guest

TOPIC: Unable to launch Headless server on Ubuntu 20.04

Unable to launch Headless server on Ubuntu 20.04 6 months 1 day ago #5241

CHC

Offline

Fresh Boarder

Posts: 5

Thank you received: 1

Karma: 0

Hello,

As stated in tu subject, I've installed YACReader on my new 20.04 LTS Server.
Before going to launch it automatically a service, I wanted to test it, but each time I try to launch, I have a warning.
christophe@jdrien:~/.local/share/YACReader/YACReaderLibrary$ YACReaderLibraryServer start
INFO  2020-05-22T13:51:27.262 YACReaderLibraryServer attempting to start
INFO  2020-05-22T13:51:27.262 ---------- System & configuration ----------
INFO  2020-05-22T13:51:27.262 OS: "Ubuntu 20.04 LTS" Version:  "20.04"
INFO  2020-05-22T13:51:27.263 Kernel: "linux" "5.4.0-31-generic" Architecture: "x86_64"
INFO  2020-05-22T13:51:27.263 Libraries:  QMap(("BDs", QPair(1,"/home/christophe/OneDrive/Books/BDs")))
INFO  2020-05-22T13:51:27.263 --------------------------------------------
INFO  2020-05-22T13:51:27.263 YACReaderLibrary starting
WARN  2020-05-22T13:51:27.264 QSqlDatabasePrivate::removeDatabase: connection '/home/christophe/OneDrive/Books/BDs/.yacreaderlibrary/library.ydb7fa27fa4de80' is still in use, all queries will cease to work.
^C

But it appears as running in ps -ax, then what is the meaning of the warning message ?
christophe@jdrien:~$ ps -ax | grep YAC
 545289 pts/0    S+     0:00 YACReaderLibraryServer start
 545291 pts/1    S+     0:00 grep --color=auto YAC

Anyway as I have no clue where to give the port I want it to run on, I am unable to connect from the iOS app to check if it's OK. I've tried with 8080 but no luck.

Do you know on which port it is listening ?

Regards.

CHC
The administrator has disabled public write access.

Unable to launch Headless server on Ubuntu 20.04 6 months 1 day ago #5242

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

The warning is caused by Luis doing something not quite right with his database code, but I gave up nagging about it years ago. You can ignore it or you can nag Luis about it :D

For finding the port, you can use one of these options to check for listening ports:

www.cyberciti.biz/faq/unix-linux-check-i...t-is-in-use-command/
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: CHC

Unable to launch Headless server on Ubuntu 20.04 6 months 1 day ago #5243

CHC

Offline

Fresh Boarder

Posts: 5

Thank you received: 1

Karma: 0

Thanks for the explanation on the warning message :-)

For the port I did the netstat -tunlpv command and found the port number, now I am able to browse the Libray.
Many thanks.

A last quaestion anyway, after having rebooted my server, the ports changed.
Do you know how to fix it or do I have to recheck for the port number on each reboot (rare I hope) ?
Why not to put it in the config file where are stored the Libraries information ?

Regards,

CHC
The administrator has disabled public write access.

Unable to launch Headless server on Ubuntu 20.04 6 months 1 day ago #5244

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

My guess is that the server randomly chooses a port because the default one is taken or it doesn't find one in the config.

The config file should be in ~/.local/share/YACReader/YACReaderLibrary/YACReaderLibrary.ini

Search for a section called [listener] and add "port=9090" or whatever (no quotes), if it isn't present create it:

[listener]
port=9090

Note that this is based on my own system, not on a fresh install, so some details might be different for you …
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: CHC

Unable to launch Headless server on Ubuntu 20.04 6 months 1 day ago #5245

CHC

Offline

Fresh Boarder

Posts: 5

Thank you received: 1

Karma: 0

Thanks for the solution
The section was tehre but not the item "port="

Added one with the right port number and everything went fine.

Have a nice weekend

CHC
The administrator has disabled public write access.
Powered by Kunena Forum