Welcome to the forum, Guest

TOPIC: .deb package available for 7.2.0

.deb package available for 7.2.0 6 years 1 month ago #769

Luis Ángel

Offline

Administrator

Posts: 1562

Thank you received: 334

Karma: 30

Hi,

Felix, with the help of Alexander and Yoann, has been working hard for getting the .deb (Amd64) package for debian based distros. You can find the latest version here. And you can follow the packaging process here

Please, help us to test the package and let us know if you find any issues or bugs.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
Last Edit: 6 years 1 month ago by Luis Ángel.
The administrator has disabled public write access.
The following user(s) said Thank You: lobo

.deb package available for 7.2.0 6 years 1 month ago #770

lobo

Offline

Fresh Boarder

Posts: 8

Karma: 0

Hi all,

Congratulations for the new package!!. I was waiting for it!! ;)

I'm using Ubuntu 12.04 and I'm trying to install this package, but I have a dependency problem: libpoppler-qt5-1 (>=0.24.5). I think my problem is because I missed some repo for that library.

Some idea how to fix this?.

Thanks!
The administrator has disabled public write access.

.deb package available for 7.2.0 6 years 1 month ago #775

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Hi lobo!

I'm sorry, Ubuntu 12.04 is just too old. It's missing more packages than just libpoppler-qt5-1. Your best option is to upgrade to Ubuntu 14.04 or newer, which has everything that is needed.
Another option would be to do a backport with qt4 instead of qt5. For that you'll have to replace the qt5 related dependencies in the source package with their qt4 brothers and compile the package. If you'd like to have a go at that I can walk you trough the process.

Regards,

Felix
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

.deb package available for 7.2.0 6 years 1 month ago #778

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Actually, you don't necessarily have to compile it yourself, I should be able to tweak my build environment sufficiently to support different versions of Ubuntu and Debian.
Give me a few days to make the necessary adjustments for a qt4 version of the package and run some tests!
No promises though ;)
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

.deb package available for 7.2.0 6 years 1 month ago #780

lobo

Offline

Fresh Boarder

Posts: 8

Karma: 0

Hi Felix,

Ubuntu 12.04 too old? come on man, it is LTS, it is still supported by Ubuntu ;) www.ubuntu.com/download/alternative-downloads

Thanks, I really apreciate you job, I'll be tunned.

Cheers,
Lobo
The administrator has disabled public write access.

.deb package available for 7.2.0 6 years 1 month ago #781

Luis Ángel

Offline

Administrator

Posts: 1562

Thank you received: 334

Karma: 30

LTS?? Boooooooo! The only good version is the latest one! :cheer:
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

.deb package available for 7.2.0 6 years 1 month ago #782

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

32 bit package and qt4 package for older distributions added. Attention! Limited support only for the qt4 version!

32 and 64 bit qt5 packages are built on Ubuntu 14.04 and should work on Debian testing or newer. Qt4 packages are built on Ubuntu 12.04 and should also work on Debian stable.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: Luis Ángel

.deb package available for 7.2.0 5 years 6 months ago #1300

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Current packages for 7.2 are available as repositories and with additional build flavors now, for details see:

software.opensuse.org/download.html?proj...mf&package=yacreader
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
Powered by Kunena Forum