Welcome to the forum, Guest

  • Page:
  • 1
  • 2

TOPIC: YACReader 8.0 for Linux

YACReader 8.0 for Linux 5 years 4 months ago #1566

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Hi everyone! It's time to talk about the Debian and Archlinux versions of YACReader 8.0 (this includes of course Debian and Archlinux based distributions as well). Compared to the previous packages and also to the non-linux versions of YACReader 8.0, there will be some changes you should be aware of:

- new decompression engine, "unarr"
- no more support for .7z and .ace
- to run YACReader, you will have to install two packages (YACReader and "libunarr")

To make installing and keeping YACReader up to date easier for the .deb users, I will provide a repository that you can add to your package sources.

So far, I'm making good progress on this, but a few details of the new decompression backend package still have to be resolved. I'll make sure to give you something to play with as soon as I am done ;)
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1571

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Ok, here we go:

software.opensuse.org/download.html?proj...mf&package=yacreader
aur.archlinux.org/packages/yacreader

If you choose to install YACReader manually on a .deb based distribution, you will also need to install libunarr manually. The package can be found here:

software.opensuse.org/download.html?proj...lmf&package=libunarr

Please let me know how these packages are working for you, especially if you run a 32 bit system. If you're running a .deb based distribution other than Debian and Ubuntu and required additional steps to install these packages, please share them. Other than that I wish you happy reading :)
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
Last Edit: 5 years 4 months ago by selmf.
The administrator has disabled public write access.
The following user(s) said Thank You: carmat06

YACReader 8.0 for Linux 5 years 4 months ago #1573

carmat06

Offline

Fresh Boarder

Posts: 17

Karma: 0

I'm not sure if this is under your control, but the opensuse.org link above is showing a 503 error.

Edit:

Its back up now. New problem, I'm running linux Mint 17.2, which is ubuntu 14.04 based. QT5.4 is not available for this distribution, does anyone know how to install the needed QT version?
Last Edit: 5 years 4 months ago by carmat06.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1574

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Hi carmat!

Thanks for your feedback. The 503 error sometimes appears when they do server maintenance. Nothing to worry about.

Now, for your real problem. This is something every user of a Debian based distribution faces sooner or later. You want or need to install a certain package, but the software on your system is too old to satisfy it's dependencies. In order to deal with this problem, special backports repositories exist, in which newer software is packaged in a way that is compatible with an distribution that shows it's age.

In order to use a backport repository, you'll either have to activate the one Mint comes with (?) or add the Ubuntu backports repository to your software sources. However, keep in mind that this will update a whole lot more than just Qt on your system. If you don't want that, you will have to manually install all the required packages, which is a very messy process I really don't recommend.

Lastly, for optimal results, don't use the Ubuntu 15.04 YACReader package. Use the package for 14.10 or Debian 8.0, they come with dependencies that are a bit friendlier for distributions with "older" software.

If you succeed, please consider writing a short guide for your fellow Mint users. I know this distribution is fairly popular, yet I can't offer direct support for it due to the dependency problem and the fact that the build service I'm using doesn't offer a Mint target.

If you run into additional problems don't hesitate to ask.

selfm
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1603

Spendoza

Offline

Fresh Boarder

Posts: 3

Karma: 0

I am also on Linux Mint, which is based on ubuntu 14.04.

I tried to run the commands listed on your install package page for the ubuntu 14.10. When I get to "sudo apt-get install YACreader" it tells me
"suggested packages:
qrencode qt5-image-formats-plugins
0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded"

When I try the manual route, it tells me
"error: dependency is not satisfiable: libqt5core5a (>=5.3.0)"

I got the tarball, but I'm a Linux noob and I don't know how to install it. Any help would be greatly appreciated.
Last Edit: 5 years 4 months ago by Spendoza.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1604

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Hi,

the Qt version in Linux Mint 17 and Ubuntu 14.04 is simply too old. To get around this problem you have to install a newer version, at least Qt 5.3. You can try the packages from here:

launchpad.net/~beineri/+archive/ubuntu/opt-qt532-trusty

If these don't work for you, you can try to get what you need from Debian 8.0 or Ubuntu 14.10, but this can get tricky in the long run.

Hope this helps.

selmf
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
Last Edit: 5 years 4 months ago by selmf.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1608

Spendoza

Offline

Fresh Boarder

Posts: 3

Karma: 0

So I tried to install the qt 5.3, but my noob is showing.

sudo add-apt-repository ppa:beineri/opt-qt532-trusty
sudo apt-get update
sudo apt-get install libqt5core5a

tells me libqt5core5a is the latest version
I don't think I'm installing the correct thing for qt 5.3.2
should I use this?
sudo apt-get install qt53base

I just don't want to screw up my install, and I really don't need a whole programmers suite taking up precious HD space when all I need is my updated comic reader lol

Thank you for your help.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1609

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Hi, disregard that repo, it's too complicated (the packages have been renamed and install to an optional location). For now, the only solution I can offer you is to use these packages from the Debian project:

packages.debian.org/source/wheezy-backpo...tbase-opensource-src

You should find everything you need there, but you'll have to download and install everything manually.

As a long-term solution, I'll try to set up a repo containing everything that is needed, but this will take a little time.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1617

Comlibro

Offline

Fresh Boarder

Posts: 1

Karma: 0

Hello,

My first post here :-) Linux Mint 17.1 user here and obviously encountering the same issues. Researched getting qt 5.3 updated and stumbled across libqt5core5a 5.3.0 package from ubuntu repo, where it recomended adding the repository to software sources so as to grab the additional dependencies:

deb cz.archive.ubuntu.com/ubuntu utopic main

deb security.ubuntu.com/ubuntu utopic-security main

After seeing what packages would be modified in synaptic, I have held off as I am unsure what the consequences of updated some 40 dependencies and removing 4 (as specified in synaptic) would have within Mint.

I am definitely a linux novice, am I on the right track here, or is this a scorched earth approach to forcing the updated Qt version?
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 4 months ago #1623

Spendoza

Offline

Fresh Boarder

Posts: 3

Karma: 0

I used the dropbox option to load my iPad, just to keep things going.
I can still get a few issues here and there, so I am willing to wait for the professional to get a package together if it means there is a lower likelihood of disaster lol
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Powered by Kunena Forum