Welcome to the forum, Guest

  • Page:
  • 1
  • 2

TOPIC: YACReader 8.0 for Linux

YACReader 8.0 for Linux 5 years 4 months ago #1641

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Give the Debian backports a try:

backports.debian.org/
backports.debian.org/Instructions/

The packages you need are all in "wheezy-backports".

If you have problems with adapting these instructions to Mint or need further information on how this will affect your system in the long run, the best place to ask about and solve these problems probably is Linux Mint's own forum:

forums.linuxmint.com/


@Comlibro:

Using vannilla Ubuntu repos's probably would work but it's a touch risky. You're better of with the Debian backports.

@Spendoza:

There's nothing I could provide for you that isn't already in the Debian backports. Getting these packages from me would give you no advantages and would come with a few additional risks.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 3 months ago #1685

avggeek

Offline

Fresh Boarder

Posts: 6

Karma: 1

selmf - one more vote/request for a repo or build that is compatible with Ubuntu 14.04. I've tried upgrading the libqt5core version in 14.04, but that fails since it requires a higher version of libstdc++. I'm wary of trying to going down a rabbit hole of upgrading packages and winding up in dependency hell. If not a proper repo, even a statically compiled version for 14.04 would be great!
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 3 months ago #1696

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

software.opensuse.org/download.html?proj...rt&package=yacreader

This is an experimental repository which should contain everyting needed to run YACReader on Linux Mint and Ubuntu 14.04.

Most of the packages in this repository are from the current Debian stable, a few are from backports and Ubuntu 14.04, not counting some helper packages I needed to import to get this working. All in all it's a pretty wild mix, so I initially didn't want to share it with you.

What you are getting:

- an easy way to install YACReader without dependency hell
- packages, that have been well tested in their respective environments (Debian stable, Ubuntu 14.10, Debian backports) but not on Linux Mint and not in this combination
- maybe some sort of trouble because these packages from different sources don't necessarily play nice in every possible situation

What you're not getting:

- support for this packages from me (seriously, Qt is a beast, packaging it is hell and I've only cherrypicked and built some already available packages for you, that's it)

- consistent updates and fixes (if I'm going to update this at all then strictly on a "as needed" basis, building this repo alone took me days)

- someone to blame if something goes wrong (you have been warned that this is experimental ;) )


Last but not least, Linux Mint will probably stay our problem child among the Debian based distributions due to the age of the software it ships and it's popularity. As I really can't provide support on these systems, it would be good to have some user-provided support here. Would any of you be willing to help other users with installation problems and such stuff?
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: carmat06, avggeek

YACReader 8.0 for Linux 5 years 3 months ago #1702

avggeek

Offline

Fresh Boarder

Posts: 6

Karma: 1

selmf - Thank you very much for taking the time to put this together! I know you said this is experimental, but it worked pretty much flawlessly for me.

I primarily run YACReader Library in a headless session and I had no real problems after the upgrade - there is a minor UI rendering glitch the first time I run the application via VNC but that clears up if I switch comics display modes. I'm happy to help out if people have problems with running it on 14.04 but my usage pattern is fairly limited.

Also, I'm not running Mint but Ubuntu LTS which is also on 14.04. I won't be upgrading till the next LTS version comes out. Hopefully that will be before the next incompatible YACReader release happens!
The administrator has disabled public write access.

YACReader 8.0 for Linux 5 years 3 months ago #1705

selmf

Offline

Developer

Posts: 553

Thank you received: 115

Karma: 11

Hi avgeek,

it's experimental because I can't do much in the case it doesn't work flawlessly. :cheer:

Technically the server part of YACReaderLibrary would work fine on older versions of Qt. The current minimum version is caused by the new GridView in YACReaderLibrary that doesn't work on older Qt.


@Luis:

Since the experimental repo seems to work out ok, could you do a little cleanup here? There is a bit of advice I've given here that has proven to be not so solid and most of the discussion is about Mint and Ubuntu LTS, so it would be better to have it in the Linux support section
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Powered by Kunena Forum